1
$\begingroup$

I am making a sword attack animation for my character and I want to parent the sword to his right index finger. I read that you have to create an empty, parent the empty to the bone and then parent the sword to the empty. When I tried doing this Blender wouldn't let me parent the empty to a specific bone, only to the whole model. It would also only act as a regular child (following the parents transforms etc.) when I was in object mode. When I tried moving bones in pose mode the sword wouldn't follow. Why is this happening and how do I fix this?

$\endgroup$
1
$\begingroup$

The correct procedure to parent the empty to the bone is:

Select the empty

Shift select the armature

Go to pose mode

Select the bone you need as parent

Press Ctrl P and choose "bone" option.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.