1
$\begingroup$

For some reason, my weight paintbrush doesn't do anything. I am using Rigify, the free Blender addon to create a rig. I used automatic weights and then go from there. I tried to weigh paint it but even though my brush is at 100% it doesn't have any effect on any part of the mesh. It won't turn the blue to red and vice versa. I am sure it's not the addon itself as it just creates the rigs, plus it's a pretty common addon. Thanks in advance enter image description here

$\endgroup$
2
$\begingroup$

It seems that you have 'Vertex selection masking for painting' ON.

enter image description here

Either turn that OFF or go to edit mode to select some vertices.

I hope this helps

$\endgroup$
3
  • $\begingroup$ Thank you! That worked however now I can't see where the vertices are. Is there any way to maintain that view while being able to paint? $\endgroup$ – Alex Sandoval Mar 2 '20 at 13:09
  • $\begingroup$ Well, you can use the Wireframe-overlay: i.imgur.com/Z7aDcb8.png $\endgroup$ – Manu Järvinen Mar 2 '20 at 13:12
  • $\begingroup$ Or, if you want to see only the vertices, select something in edit-mode and turn the 'Vertex selection masking for painting' ON again in the Weight-painting mode $\endgroup$ – Manu Järvinen Mar 2 '20 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.