0
$\begingroup$

I'm creating some low-poly terrain in blender by starting with a grid, then pulling vertices up vertically using a random falloff to affect nearby vertices.

I've ended up with some normals that face under the terrain, rather than above it:

Top top view

Bottom bottom view

When I Flip Normals, the normals change slightly, but still face under the terrain.

Bottom after flip bottom after flip

Recalculate Outside/Inside does not work either. how can I make the normals of these 3 faces point towards the top of the terrain, like all the faces around them?

$\endgroup$
4
  • 1
    $\begingroup$ You can hit ALT+N > F to manually flip the normals of those selected faces. Often when SHIFT+N to recalculate normals doesn't give a correct result, it can mean something is wrong with your mesh, especially if the solution should be simple and obvious as in this case. Check for non-manifold geometry or doubled vertices. $\endgroup$
    – Rekov
    Commented Feb 29, 2020 at 22:21
  • $\begingroup$ Thanks @Rekov. There's no doubled vertices or non-manifold geometry (had to look that one up). I just turned on backface culling and the faces render as expected. I wonder if there's just some visual glitch in the normals overlay. $\endgroup$
    – rcorre
    Commented Mar 1, 2020 at 13:17
  • $\begingroup$ Yeah that's really odd then. Anyways, if you want, you can always upload the blend file to blend-exchange.giantcowfilms.com if you want someone to take a look. $\endgroup$
    – Rekov
    Commented Mar 1, 2020 at 16:15
  • $\begingroup$ blender.stackexchange.com/questions/282322/… $\endgroup$
    – Harry McKenzie
    Commented Feb 14 at 15:14

2 Answers 2

0
$\begingroup$

First, to see the normal orientation for objects, at least in the Layout and Modeling workspaces, select the Overlays dropdown and then check Face Orientation. The Overlays dropdown is above the Transform panel. Blue faces are correct and red faces are flipped.

Next, go into Edit Mode, select all, then press ⇧ Shift + N. Or press Alt + N for a menu. If this works, great, stop here.

Lastly, if there are any Modifiers attached to the object, look for a Normals Panel and uncheck the Flip option.

Moreover, I know for sure that the Solidify modifier has this option. Perhaps other modifiers as well. And, if you have multiple modifiers attached to an object, be sure to look through all the Modifiers for a > Normals panel and uncheck the Flip option in each Modifier.

I am using Blender 3.6.2

$\endgroup$
1
0
$\begingroup$

Know that this should not be possible as long as you merging verts. But when looking on your second picture seems looking like you had two faces on same verts, both facing different directions.

Could you make diagonal edge (J) on the vertices like this.

$\endgroup$
1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .