2
$\begingroup$

My object behaves weirdly in Viewport's Solid Mode, it's shown like this in the Solid Mode:

enter image description here

But when I render the scene, it's shown well (as it should be):

enter image description here

It only has a Bevel modifier:

enter image description here

The object in the Edit Mode (Solid Mode):

enter image description here

Edit Mode + X-Ray Mode (in Solid Mode):

enter image description here

Edit Mode + X-Ray Mode (in Wireframe Mode):

enter image description here

How can I fix it?

$\endgroup$
0
$\begingroup$

Bevel modifier, when applied to the whole of complex meshes in particular, can mess things up. To avoid this model the shape from a subdivided, 8×8, plane removing undesired vertices/edges. Bevel it, selected vertices only (it's called a vertex group), to obtain rounded corners as shown below. Extrude it when done and remove doubles.

enter image description here Use knife project with the cut through enabled for the rounded holes as the rectangular hole is the subdivided faces deleted.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Can you please explain it more clear (what exactly should I do?)? Thanks $\endgroup$ – H. Farid Feb 29 at 16:28
  • $\begingroup$ I added an explanatory image. $\endgroup$ – Lukasz-40sth Mar 1 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.