I have tried to set the origin of a mesh using "Origin to Geometry", "Origin to Center of Mass (Surface)" and "Origin to Center of Mass (Volume)".

None gave me the correct result.

Here is the blend file.

What am I doing wrong?

Thank you.

enter image description here

  • $\begingroup$ I'm not sure I follow, but you can position the 3D cursor to where you want the origin to be and set it there. $\endgroup$
    – Chris
    Feb 27 '20 at 21:38

Because your mesh is fatter at the bottom than it is at the top, the center of mass by volume and by surface are toward the fatter end of your mesh.

Your best bet is to position your 3D cursor where you want your origin to be, and then set the origin to the 3D cursor.

  1. In Edit Mode, select one vertex on each end of your mesh. In your case this is easy because you have conveniently centered vertices.

  2. Hit SHIFT + S and choose 'Cursor to Selected'

  3. In Object Mode, set the Origin to 3D Cursor.

enter image description here

  • $\begingroup$ What a great tutorial. Maybe I ask you which numpad key you have used to show the model in frontal view? I have used 1, and that showed me the bottom. Edit: I got it: 7. $\endgroup$
    – tmighty
    Feb 27 '20 at 22:07
  • 1
    $\begingroup$ Good answer :). Just to add - since 2.81 you can directly move the origin point with the Move Tool. It's faster in some situations. $\endgroup$ Feb 27 '20 at 22:25
  • $\begingroup$ @tmighty Numpad 1 is Front view, and Numpad 7 is top view. In Blender 'Z' is up, not 'Y' like in Unity for example, so your model is technically lying on its side. You could rotate it 90° about the X axis to get it upright. $\endgroup$
    – Rekov
    Feb 27 '20 at 22:52

I understand that you want the origin to be at the centre of the bounding box. Origin to Geometry will do this if you first set the transform pivot point to Bounding Box Center. (The button for setting the transform pivot point is the second of the four buttons near the centre of the 3D Viewpoint header.)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.