1
$\begingroup$

hi so i'm creating a high gloss golden earring with a pearl detail, but both textures are coming out black in baking (the object is merged because the programme i plan on uploading to can only have file sizes of a certain size). i'm using some random hdri i got for free online, so you can play around with that when you experiment, i won't be too butthurt. I honestly don't kniow what i'm doing wrong. I've tried baking the following combinations of nodes for each texture (seeing as they both have similar levels of glossiness, i just did the same for both and changed the colours/roughness):

combination 1: fresnel node, diffuse bsdf, glossy bsdf, plugged into a mix shader (i also tried this without the fresnel, no change)

combination 2: principled bsdf, glossy bsdf, plugged into a mix shader (also came out black)

here's my blend file: https://www.dropbox.com/s/nldwlauxfutffx4/vintage%20gold%20earrings.blend?dl=0

go crazy if you want, i'd just really like to know wtf i'm doing wrong because i'm creating quite a few shiny objects for various projects at the moment and i'm (somewhat) consistently getting this issue, and sometimes i fix it but idk how, sometimes i don't. so yeah, any help would be GREATLY appreciated.

$\endgroup$

2 Answers 2

2
$\begingroup$

A lot of objects are hidden for the viewport, but visible for the render. Since a baking is a render, those objects cover your main object and prevent the light to hit it.

enter image description here

Click the "funnel" icon (Filters) then activate the "camera" icon (Disable in Renders). Then for each object in the list where the "eye" icon is unchecked, uncheck the "camera" icon.

$\endgroup$
1
  • 2
    $\begingroup$ The fact that the Disable in Render icon is now hidden by default, don't make our life easier on stackexchange... $\endgroup$
    – thibsert
    Feb 27, 2020 at 12:56
1
$\begingroup$

Thibsert beat me to it :)

I'm posting this screenshot just in case it is helpful.

Basically, disable any objects in the scene that may interfere with the bake by unchecking the little camera icon (disable in renders), before hitting that bake button.

**enter image description here**

Next time, try adding seams before unwrapping, That way you will have nicer UV unwraps to work with. :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.