4
$\begingroup$

I might just be overlooking a really obvious way to do this, but here's my issue. I want to make all of the triangles shown here completely flat. I know I could just scale them along the z axis but they need to be the exact size they are now.

This is the project I'm working on:

enter image description here

This is the top view of my project. They all look fine from here, but when you look at the side view:

enter image description here

You can see they're all at different angles. So is there a way that I can make them all completely flat without changing the scale?

$\endgroup$
  • $\begingroup$ Do you mean proportions and size ... rather then scale? Scale often means the setting in the object panel. $\endgroup$ – atomicbezierslinger Feb 25 at 22:07
  • $\begingroup$ Is this one mesh or many meshes? Are they rotated when you inspect the rotate settings in the object panel for properties? Would it just be easier to discard a few items and start from the beginning? If you had 100 planes the work might be more concerning. $\endgroup$ – atomicbezierslinger Feb 25 at 22:11
  • $\begingroup$ Another screen capture showing properties would reveal more. The existing screen capture reveal somethings. $\endgroup$ – atomicbezierslinger Feb 25 at 22:13
  • 1
    $\begingroup$ You want the triangles to remain undistorted? i.e. they should be rotated into place? $\endgroup$ – Robin Betts Feb 26 at 8:17
3
$\begingroup$
  • Add a big plane under your triangles.
  • Important : Apply any rotation to your triangles first with CTRL + A > rotation
  • Add a "Shrinkwrap" modifier to one of your triangles. Set it to "project" along "Z" and choose "Negative". Set the plane in the target field.
  • Select all your triangles and lastly the one you added your modifier to. Type CTRL + L and choose "modifiers"
  • Apply all the modifiers at once with Object > Convert To > Mesh objects

enter image description here

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Finally this is similar to scale Z 0 and apply scale when the pivot point is set to active element? $\endgroup$ – lemon Feb 26 at 10:46
  • $\begingroup$ Exactly, but what can I say, I like complicated things. And non-destructive modelling $\endgroup$ – Gorgious Feb 26 at 10:49
  • $\begingroup$ Anyway the question is a bit unclear and your result is probably the good one. $\endgroup$ – lemon Feb 26 at 10:50
  • $\begingroup$ Well I agree that the question is unclear, judging by the comments and answers, but at least we're exploring new possibilities and I think the other ones work too ! Obviously "S-Z-0 G-Z-***" would be the easiest and fastest one $\endgroup$ – Gorgious Feb 26 at 10:56
7
$\begingroup$

First create a plane that you would like to align them all to.

Second If they are not already individual objects, go into edit mode and hit P to separate by loose parts.

Then enable snapping by clicking the magnet button and set up the settings as you see here:

Snap settings

Finally, select the parts in object mode hit G to move them. Put your cursor on the plane, then they should rotate to match the plane.

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ This didn't work for me, they're just snapping down to the plane with one of the points straight up $\endgroup$ – christina Feb 26 at 4:08
  • $\begingroup$ If your points are off because of vertices rather than object rotation you can do the same steps. Just go into edit mode, select the vertices with the above snapping settings enabled, and move them on the z-axis. $\endgroup$ – Michael Feb 27 at 19:04
5
$\begingroup$

You can simply snap them to a flat floor.

  1. Add a flat plane
  2. Set snapping to Face > Align rotation To target
  3. Use the Move Tool to move them down - they will snap flat to the surface

enter image description here

|improve this answer|||||
$\endgroup$
  • 1
    $\begingroup$ Great animation. I would love to make better explanations using something similar. What did you use to capture this? $\endgroup$ – Michael Feb 26 at 0:04
  • 1
    $\begingroup$ @Jachym This didn't work for me. They are just snapping down to the plane with one of the points straight up. I don't really know how to explain my problem, if you explain how you made that video i could do the same, showing my problem $\endgroup$ – christina Feb 26 at 4:06
  • $\begingroup$ Hello @Michael :). I use Licecap for gifs, set to 18 frames, 800x400px. It's easier than taking multiple screenshots :). $\endgroup$ – Jachym Michal Feb 26 at 7:50
  • $\begingroup$ Hello @christina :). This can have multiple reasons. Consider sharing your .blend file so others can take a look. $\endgroup$ – Jachym Michal Feb 26 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.