Blender 2.81
I frequently change the Gizmo orientation in modeling between Global and Normal. There is no shortcut shown.
The Blender documentation says , (comma), but using comma the orientation shown at the top right side is changed, not the one I need (marked red in the picture below). Both have the same tool-tip though. Comma shortcut with round selection doesn't change wanted orientation

So there are two questions:
Important: What shortcut shall I use to change the highlighted orientation?
Out of curiosity: What orientation do I change using the comma shortcut and what is the correct name for the orientation I need. Both say "Transformation Orientation".


2 Answers 2


While both "Transformation Orientation" options have the same tool-tip, they are used at different times.

The left one you marked, is used for gizmos and only when you grab the gizmo and use it, overwrites the "globally" used one to the right.

While the right one is used when you use the G,R and S keys to move, rotate, scale respectively as well as other functions like E for extrude etc.

Only if you use gizmos, will the left one be used, as it also only becomes available when the gizmo is activated. It can be seen as giving the tool it's own specific orientation option.

The documentation is sadly referring to the same link/explanation for both menus. After looking through the key-mapping, and checking in the console regarding what is reported when changing the selection for either of the two transformation orientation options, i found, that both set the exact same variable:

bpy.context.scene.type = 'LOCAL'

So using , you only get the pie menu to change the right "globally" used "Transformation Orientation", and it seems to me that there is no key for the tool specific options on the left, neither for a pie menu to change them. And adding a shortcut for those tool specific transformation orientations is not possible either.

That sadly means, that there is no solution i can offer you aside the explanation.


If you set the left orientation to Default, the comma shortcut will work for gizmos in object and edit mode. Note: I am using Blender 2.92


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .