1
$\begingroup$

I created a simple wall in blender using Archipack but any time I change it, height etc, it deletes all my windows, A little reading indicates that I must make it "safe to edit".

"In order to prevent any parameter edit and get a “safe to edit by hand” non-archipack aware mesh, use either “selected” or “all” found in Archipack Tools -> Kill parameters."

But nowhere does anything say WHERE the Archipack Tools are to find this option.

https://gyazo.com/c765953ad916dfdbd2305533760e194c

It's not in my right-click where I managed to get Loops tools to show up once. It's not down the side with the Archipack - all I get there is the Material and the wall itself with its details.

(The answer below says that it should be in the side menu accessible by pressing N. I don't have "Tools". Extended Tools is from a Modeling Cloth add-on.) enter image description here

$\endgroup$
1
$\begingroup$

In free version you must remove archipack parameters using python console. Take a look at custom properties in mesh tab, you'll find the name of the property to remove. (for wall it is archipack_wall2)

Select your wall, then in python interactive console, enter

C.active_object.data.archipack_wall2.clear()
$\endgroup$
2
  • $\begingroup$ Thank you for your response, however, I bought the upgrade - which has a whole new batch of issues. For example, the location of the material lib in the instructions does not exist on my pc. Also, I upgraded blender the same time and nothing works, clicking and selecting and dragging and my space navigator is all backward and won't zoom, can't click on the arrows to move the wall creation object, can't scale when an object is selected, it draws a select box. I can change drag to active tool in a blank blend, but can't figure how to change that to the default . $\endgroup$ – J L Lacy Mar 1 '20 at 3:12
  • $\begingroup$ For commercial version support request, please use customer channel. $\endgroup$ – Stephen Leger Mar 2 '20 at 5:44
0
$\begingroup$

In the 3D view workspace, press N or click on the left pointing arrow on the top right corner. Go to the "Tools" tab, there you can find what you are looking for.

enter image description here

$\endgroup$
2
  • $\begingroup$ Thank you for your answer - however, I don't have that option. Is it something I need to add to the sidebar somehow? gyazo.com/13c89cc7b6c5841fa401e539ebce8a65 $\endgroup$ – J L Lacy Feb 24 '20 at 13:42
  • $\begingroup$ Right, I don't see this option either when I activate the free version. I can't find it. $\endgroup$ – Gorgious Feb 24 '20 at 14:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.