How can I make the lamps (area/point/spot) visible to camera in Cycles render? Currently they are invisible to the camera, unlike custom mesh lights which can be seen unless camera visibility turned off.

I would like to see the lamp (ie point/sphere) directly in the camera.

  • 4
    $\begingroup$ You cannot make default lamps visible in neither Blender Internal nor Cycles. $\endgroup$
    – iKlsR
    Commented Jul 6, 2013 at 15:03
  • 4
    $\begingroup$ You can work around this by using very small mesh lamps instead $\endgroup$
    – Gwen
    Commented Jul 6, 2013 at 15:10
  • $\begingroup$ What do you mean by "visible"? Are they not emitting enough light? $\endgroup$ Commented Jul 7, 2013 at 13:15

4 Answers 4


The standard lights can't be made visible, it only works with mesh lights. I think this is because blender treats lamps different to emitting surfaces when rendering.

  • $\begingroup$ this is no longer true ... it works now take a look down and upvote the now correct answer pls :) $\endgroup$
    – J.Doe
    Commented Nov 24, 2022 at 15:41

As others have said, Cycles doesn't do that, but you can work around it with proxy objects that are only visible to the camera. Create a small sphere, parented to the lamp, with a node setup like this:

Proxy Object for Light Source

This will make the sphere directly visible to the camera, but it won't affect your scene in any other way.

This works nicely for point lamps. Other lamp types could be a bit more involved, depending on the look you're going for, but the same principle holds.

Sun lamps are especially tricky because the proxy needs to be handled in the world shader setup, and can't be parented to the lamp. Set up your world shader nodes like this:

Nodes to make the sun visible to the camera

You can replace the sky texture here with whatever you want the rest of the sky to look like.

You can see from the purple highlighted elements that I'm using drivers to effectively parent to the sun, and to mimic its actual size. You don't necessarily need to do that, but it's handy. Full details would be out of scope for this post, since you didn't specify sun lamps, but the setup is available on Blend Swap if you're interested.


With the light selected, enable 'camera' under the ray visibility option :)

enter image description here


edit: as of Blender 3.3.1 it works via Ray Visibility

If someone comes by and just needs a quick and dirty workaround: Place a plane with a Glass shader in front of your Camera. This will make standart Blender Lights visible to the Camera.

Note: this will be slowing down your overall Rendering and probably come with some other sideffects. To speed up rendering set IOR and Roughness to 0.

Also there is someon workin on a Patch... no idea if it will be merged though.
Issue: https://developer.blender.org/D3433
Topic: https://devtalk.blender.org/t/area-lights-still-not-visible-in-cycles/9430


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .