I wanted to make my own 3d model to use as part of my game inside of Unity. This is the first time i used blender. I watched some tutorials and created my basic model, wich worked fine.

Than, I started Rigging the Model, wich did also worekd at some way. I parented the Rig to the Body. (It is displayed as a parent, so this should have worked). I used automatic weights.

When in Pose mode, to move my bones around, nothing happens. The Bones are moving - The body is not. I searched in the web but couldn't find any awnsers.

It would be really nice, if someone could help me, what i made wrong. If you want to see my model: https://drive.google.com/open?id=1kLMnq8uy9orStyIPaPJ2f755zKODz8a8

Thanks for your help ~BrainyXS


1 Answer 1


You parented the rig to the body.

But you should be parenting the body to the rig, so you select the body then hold SHIFT and then select the rig (in object mode) then press CTRL+P then choose with automatic weights. After that try moving the bones in pose mode.

Don't forget to let me know if that works or not.

You might have to remove the first parent to do this.

Good luck.

  • $\begingroup$ Thanks a lot, this worked!!! $\endgroup$
    – BrainyXS
    Feb 21, 2020 at 16:12
  • $\begingroup$ You are welcome. Have a nice day $\endgroup$
    – moslem770
    Feb 22, 2020 at 9:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .