1
$\begingroup$

Whenever I add a Quick Smoke effect, I can't preview it on the viewport unless I bake it.

And Yes, I added the Smoke Domain on the object.

I've seen tutorials like this https://www.youtube.com/watch?v=VmRqlsuSvsw and this https://www.youtube.com/watch?v=_IDBfQnttiE that clearly shows the possibility of previewing the smoke before baking it.

I'm using Blender on a Mac with AMD GPU. I would guess that this is something related to OpenGL, as thoroughly explained here - Why is the smoke preview not showing in Blender's viewport? but that's for Windows.

Does anyone have any idea how to fix this?

$\endgroup$
4
$\begingroup$

Fixed it. The default Cache Type is set to "Modular". In order to see the Smoke preview in the viewport, it's necessary to switch it to "Replay". enter image description here

Big thanks to Pablo Vazquez that found this solution on Twitter.

| improve this answer | |
$\endgroup$
1
$\begingroup$
  1. Select smoke domain
  2. Open Physics tab
  3. Check Cache Type

If you want to stay on Modular in settings click Bake Data or change to Replay.

enter image description here

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.