1
$\begingroup$

I am new to blender, and after I created a text object, I found it had a black material along its edge.

Here is view display and render display, which shows the problem. I don't know understand what is causing this. It looks unrealistic and bad—is there any way to beautify it?

enter image description here

Render image

$\endgroup$
7
$\begingroup$

Sadly it's because of default Smooth shading (Normals) on extruded part of Text object.

enter image description here

You can fix that by adding Edge Split modifier.

enter image description here

Or you can search Convert to Mesh and enable under Data Properties > Normals > Auto Smooth. But you would not be able to retype your text.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.