0
$\begingroup$

I am in need of help. I was trying to complete a smoke tutorial, but I needed to update Blender. After I had updated to 2.82, I had put in all of the desired values into their designated slots. I pressed Bake, and afterwards I tried to look at the results through all four Viewport Shading displays (Wireframe, Solid, Material Preview, and Rendered). At first I could see the smoke in Wireframe and Solid, but only if I don't place a Principled BSDF node. If I do, it is invisible no matter what.
If anyone has any suggestions, please let me know. Below is the screenshot. The emitter is in the red circle, a small plane. The emitter is in the red circle, a small plane.

Edit: I searched some more on the internet for answers. It appears that I have a Graphics Card that is incompatible with Blender, a Radeon Pro Vega 64 16 GB. The only graphics cards that are supported are from NVIDIA, Intel, AMD, and Macs with software with an IOS version of 10.12 or older. That is most likely why it shows up with the message "No compatible GPUs found for path tracing" when I try to render the smoke with CUDA or OpenCL. The CPU works fine, so that is why only Cycles works. However, even if I switched to Cycles and CPU processing, the "Render" Viewport Shading Display just fills up with blocky black and red pixels, instead of a single cloud.

Edit 2: I believe I found the solution! I now was able to see both modular and replay in WINDOWS rather than Apple, but now I found out that it renders the same image over and over again when I wanted to hit Render Animation. I created a new question that is more related to that rendering issue, rather than this Viewport issue.

$\endgroup$
0
$\begingroup$

I'm sorry if this is a dumb answer...but is your inflow (the plane) inside the confines of the domain? If it is even with the borders, or slightly outside the domain of the domain i don't think it will work. I think it needs to be totally inside.

$\endgroup$
3
  • $\begingroup$ Slorry not "outside the domain of the domain", I meant outside the borders of the domain. $\endgroup$ – Porker 574 Feb 20 '20 at 1:52
  • 1
    $\begingroup$ Please edit your answer rather than comment it. Thank you $\endgroup$ – vklidu Feb 20 '20 at 6:22
  • $\begingroup$ I've tried that, but the smoke is still invisible. $\endgroup$ – Felt_Notebook Feb 21 '20 at 22:42
0
$\begingroup$

Go to cache settings of the domain and change the type from modular to replay

$\endgroup$
2
  • $\begingroup$ I have found a solution that is not related to selecting those two options, but thank you for the suggestion though! $\endgroup$ – Felt_Notebook Mar 10 '20 at 1:35
  • 1
    $\begingroup$ do you mind sharing how you fixed it then? $\endgroup$ – Robin Bervini Mar 25 '20 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.