1
$\begingroup$

I use Blender to create 3D models for printing. Occasionally when I select mesh by trait - interior faces, the results shows some exterior faces selected.

I tried to use Mesh > Normals > Flip to fix this but nothing happens. Same for recalculate exterior faces.

I've also tried the 3D model plugin to "Make Manifold" but it removes the selected faces.

The solid model looks correct but will not print correctly.

Is there a way to fix this?

Solid model looks correct

enter image description here

$\endgroup$
2
  • $\begingroup$ Does it conected to a mesh or is it separated? I mean when you select a vertex and hit L key does it select all vertices or only highlighted part on your screen? $\endgroup$
    – vklidu
    Feb 20, 2020 at 6:38
  • 1
    $\begingroup$ I think you would have more than one issue :-) here are nicely documented all possible issues check it out sculpteo.com/en/tutorial/prepare-your-model-3d-printing-blender/… $\endgroup$
    – vklidu
    Feb 20, 2020 at 7:00

2 Answers 2

1
$\begingroup$

When you have trouble with Normals, i would highly recommend the following.

  1. Go in the Viewport Overlays and activate "Face Orientation" enter image description here
  2. You should now see red and blue overlay on your object (blue face direction should always point outwards, red the backside of faces and should only point inwards)
  3. Go in Edit Mode and press A to select all
  4. Press Shift+N to recalculate normals outside
  5. If there are still red areas facing outwards you need to select them manually
  6. Press Alt+N and Flip those Normals

Now the entire object should be blue and you can deactivate the "Face Orientation" A little tip, add Flip and show Face Orientation to Quick Favorits per RMB It's so helpfull to have at hand and saves a lot of time.

Important is that only selected faces will be affected by the normal operations.

Interior faces as the tooltip says are faces were all edges have more then 2 face users!

enter image description here

Means faces that cover holes where more geometry is hidden behind.

Here a little visual explanation about it:

enter image description here

It's obvious that there are faces hidden behind the middle one covering a hole. I believe you may have generated overlapping faces that lie above/in front of others that are facing outwards. Try saving the file incremental and then select those interior faces and hide them with H. Should those now hidden faces not affect the mesh, just press Alt+H to show them again and delete them with X, "Faces".

$\endgroup$
2
  • $\begingroup$ Thanks, I have done all of that and the blue pointers indicate that the normals are facing outward. But then when I check again with mesh "Select all by trait - interior faces", the same faces are still selected. $\endgroup$ Feb 20, 2020 at 2:22
  • $\begingroup$ Those faces should be either unneeded or are in front of faces that are hidden and are not needed. $\endgroup$
    – Xylvier
    Feb 20, 2020 at 8:01
0
$\begingroup$

To test: Add cube, duplicate 6x along x with grid snap on. (Move each duplicate cube along the axis so that the two cubes' side faces 'touch'). Take this group duplicate 6x along y with grid snap on. Then take this group duplicate 6x along z with grid snap on. You should now have a nested 'cube' made up of 216 smaller cubes with no gaps.

Now delete some random inner cubes and a few of the cubes making up the 6 walls of the larger cube. Something like Minecraft. You should be able to travel through tunnel-like spaces through the large cube.

Select all remaining cubes and join them into one mesh (Object>Join).

In Edit mode, select all vertexes. Go to Mesh>Merge>By distance. Set distance to around 1.2m to select all double and remove them.

Then, still in Edit mode, on Face Select, go to Select All By Trait> Interior Faces.

And there's the problem: While Blender does select most of the included/occluded interior faces, it doesn't select all of them. And, additionally, it selects some faces that are exterior facing.

This is not what is supposed to happen. It seems quite random and unreliable and needs to be fixed.

Whatever algorithm / coding is used to execute this process is not fit for purpose and another method must be found to perform this (should be) useful function.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .