0
$\begingroup$

I'm on Blender 2.8, and am trying to make an animation of a ghost knight, with flames flowing from behind the visor and under the mail hem. To make it look nice, I used particles to animate the visor and hem flames, and using the flame physics kit for the arms wreathed in flame. Problem is, now that I've got the model animated, I noticed that the particles' emission spot doesn't move from the emitter's default location, even if the emitter itself does. I know this question has been asked before, but of the two I found on the site, one had an answer which doesn't work in my instance, and the other wasn't answered. And before you ask, using hair particles isn't an option to my knowledge, as I can't animate that in a satisfactory manner.

Character in default position Here's the character in it's default position, with emitters highlighted.

Character mid-animation And here's the same character, with emitters still highlighted, mid animation. Note how the particle stream remains in the default position despite the emitters moving with the character's animation.

I've tried baking and re-baking the particles, to no avail.

$\endgroup$
1
  • $\begingroup$ Please show your work or some simplified version of you work as a Blender screen capture. Simple version which fails to meet your expectation is even better. I may or may not understand 50% of what you wrote. I might understand more if you show your work as a Blender screen capture. I wonder if that is true or other readers as well. $\endgroup$ – atomicbezierslinger Feb 19 '20 at 16:02
0
$\begingroup$

Particle System has a bake option you wil see in the Panel. You will probably need it.

If you have a previous bake. Delete the bake. Then bake again.

If you never baked. Try baking for the first time.

Remember to bake after every significant change. The particle system will not let you change parameters when a bake is active. Yet you can change other objects such as physics obstacles. I have not checked every version of Blender 2.8X yet at one point there were obvious defects in the Particle System.

$\endgroup$
0
$\begingroup$

Nevermind, I worked it out. The easiest solution is to( remove any existing bakes,) slap a ChildOf constraint on the emitter linking it to your armature on the relevant bone, and then bake your particles.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.