2
$\begingroup$

I am having a bit of a hard time understanding why the STL export differs from what I see in my model.

Currently I am trying to create a 3D printable mould to create beeswax foundation. I have created a small example of the problem I am facing.

In Blender my model looks perfect, each hex has 3 edges meeting in the center of the cell, the mid point is then moved up 1mm to form the indent in the mould. Here is what it looks like in Blender, you can clearly see the three faces. enter image description here

However when I export as STL and pull it into Prusa Slicer, I end up with 6 faces, which is not what I am after. enter image description here

You can find my blender file here

Any suggestions welcome.

$\endgroup$
3
$\begingroup$

If you need the quads to be planar

The cap-quads can be planar and symmetrical only if D is brought into the plane defined by ABC, in which case the cap is flat, or B is brought into the plane defined by ACD.

enter image description here

One way of taking the second option would be to create an equilateral triangular pyramid with the desired pitch, and looking straight down Z, Knife Project a co-centric hexagon down onto it:

enter image description here

You can then delete unwanted faces before extruding the perimeter downwards and SZ0 flattening it about the appropriate pivot.

enter image description here

$\endgroup$
4
$\begingroup$

What you see here is automatic triangulation. You have quad faces in your model that are not planar and polygonal faces that are not planar cannot be printed so they are triangulated and since there is no way for a computer algorithm to determine where to insert the edges it sometimes fails to guess.

The solution would be to enter edit mode with your object selected(tab) and use something like the knife tool(k) to triangulate the mesh manually so it fits your expectations. you can also join vertices with an edge by selecting 2 vertices and hitting j.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.