2
$\begingroup$

I am experiencing a strange lighting effect with my last 2 rendered video animations in Blender.

The only thing I think my last to video animations had in common is the presence of more than one source of light in the fixed camera scene.

At random times during the animation strong and 1 frame long flashed of light appear. They have the colour of one of the lights present in the animation in the screenshot below you can see one of these flashes.

enter image description here

I would like to know what I am doing wrong and if I can eliminate all the flashes.

Thanks in advance.

$\endgroup$
9
  • $\begingroup$ Try lowering the bloom threshold $\endgroup$
    – Gorgious
    Feb 19, 2020 at 9:30
  • $\begingroup$ currently, the bloom threshold is 8 should I bring it down to 3 or 2 or go up to 100 because it seems the more I go up the less the light effect? $\endgroup$
    – ronin074
    Feb 19, 2020 at 10:09
  • $\begingroup$ Maybe you have accidentally keyed the light intensity. $\endgroup$
    – Bruk
    Aug 9, 2020 at 7:11
  • $\begingroup$ do you mean I keyframed in the lights during the rotation animation? I checked for keyframes in the lights timeline but there were not. $\endgroup$
    – ronin074
    Aug 9, 2020 at 7:24
  • $\begingroup$ What version of Blender are you using? In alpha stage of Blender 2.80, this happen a lot in my experience when volumetric are enabled in my scene. At that time, I manually replace the corrupt image with the re-rendered one. Which is not a good solution $\endgroup$
    – HikariTW
    Aug 10, 2020 at 8:07

1 Answer 1

2
+50
$\begingroup$

I just ran into what may be the same issue rendering out some of my scenes with eevvee. See screen shot. I did a bit of investigation and where I have a stack of point lights in a complicated mesh every now and then I'll get that flash. If I turned off bloom it stopped, looking at the rendered image it would have a few super white pixels for some reason that bloom was really blooming on causing the flashes.
I added a clamp value to the bloom (20 in my case worked) and it stops that happening. To re-render the affected scenes without redoing the whole thing I tweaked my command line batch render as below just to re-render the affected frames.

"--path to your blender install--\blender.exe" -b "P.Scene4.Cut1.blend" -f 2,5,36,51,52,53,70,75,77,78,104,105,114,119,137,149,169,174,186,221,232,233,241,246,247,250,252,259,266,276,277,280,283

Perhaps you issue is different but check bloom clamp, 0 is the default and that means no clamp at all.enter image description here

$\endgroup$
4
  • $\begingroup$ I am rendering with 20 clamp right now. $\endgroup$
    – ronin074
    Aug 13, 2020 at 11:51
  • $\begingroup$ Cool let me know how it goes! FYI on some of my other scenes where I Also had issues and I had a lot of bloom going on I upped the clamp setting to 200 (this actually allows more bloom) and it still worked to stop the flashing so if you find 20 reduces the overall bloom too much for your taste but did resolve the issue try something around 200. Good luck! $\endgroup$
    – Mark
    Aug 13, 2020 at 17:01
  • $\begingroup$ Tried at 30 and the flashes were reduced a lot. I will try at higher and see how it goes. $\endgroup$
    – ronin074
    Aug 14, 2020 at 15:52
  • $\begingroup$ The render went quite well but not perfect. At 30 clamp bloom flares were much reduced but still present. At 200 clamp again bloom flares were much reduced but still present. However, I did as I was once suggested and corrected the defective frame in the sequencer and rendered the animation again perfect this time. $\endgroup$
    – ronin074
    Aug 15, 2020 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .