0
$\begingroup$

I'm using blender 2.82 and the rigify add on. I tried to do a dragon rig and even though its not perfect it works for now. At least in blender... when i try to export it the spine causes some weird twitching. i already read tons of threads but no solution worked for me. like the gamefriendl script by paolo https://developer.blender.org/p/pkrime/ or the shear patch i alredy checked for non uniform scales but havent found any (in the fbx there are some but even putting everything back to 1 doesnt help...) the only thing that kind of worked was usind the origional bones instead of the def bones, but hat causes new problems.

does anyone have an idea what im missing here?

$\endgroup$
0
$\begingroup$

Well i dont think i'll get an answer what i did wrong but maybe this will help someone else in future.... I still havent found the reason for this behavior but I think I finally found a workaround that works and you dont have to do much for it. while the first workaround was using the origional bones as deform bones and renaming the vertex groups whick caused trouble with some weights and the tail looked messed up, because the origional bones move differently than the deform bones I noticed that i could exchange some Origional bones within the spine with their deform bones without getting the twitching again. so i tried to exchange only the parent of all spinebones (the bone at the end of the tail) and it worked for me. no more twitching in unity.

so the detailed steps where (my way):

  1. find the rootbone of the evil twitching (first spine bone in my case)

  2. rename the prefix of the deformbone (i used fill-spine..),clear the deform checkbox and move it to another layer (not neccessary)

  3. take the Origional- bone (ORG-...) counterpart of that bone, move it to the deform layer, tick the Deform checkbox and rename its prefix to DEF-...

  4. Parent the rest of your def rig to your new bone.

  5. maybe you need to rename the vertexgroup for that bone, because it automatically changes in step 2. (in my case change Fill-... back to DEF)

Let me know if there is a better way :)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.