0
$\begingroup$

When I bake the normal map, it gives me the shading artifacts from the low poly mesh.

I tried countless times, but I can't find out what is wrong. Does anyone know what is going on?

Here are some photos, thanks in advance.

enter image description here enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

The reason that the lighting looks strange is that the low-poly model uses triangles instead of quads. When using smooth shading together with the triangle-based mesh, blender has trouble interpolating the normals.

The fastest solution but maybe not the best would be to simply use flat shading on the low-poly mesh instead of smooth shading.

Ideally, you would want the low-poly mesh to be made of quads. The practice of making a low-poly quad model from a high-poly model is known as retopologizing, and there are tons of tutorials out there on how to do it. This video from CGMatter shows an easy way to do it automatically. Your high-poly mesh seems to already have good topology (i.e. quads), so another option would be to simply make a copy of the high-poly mesh and dissolve some of the edge loops.

$\endgroup$
  • $\begingroup$ The low poly mesh typology is like that because I made it for games, the problem still persists with simple meshes that have all quads $\endgroup$ – Smeckdown 21 Feb 16 at 15:42
  • $\begingroup$ It seems like the baking isn't the problem, but the way the smooth shading interpolates between the normals of the different faces. When there's less geometry to work with (even if it's quads), as seen in your third image, the interpolation is generally going to look worse. You can fix this by adding more geometry around the edges, (adding loop cuts for instance), or by using flat shading instead of smooth. $\endgroup$ – Oscar Feb 16 at 20:08
  • $\begingroup$ Thanks, now it's working a little better It still has some problems, but it's bearable, by the way, this problem didn't appear when I baked some normal maps for testing. $\endgroup$ – Smeckdown 21 Feb 17 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.