0
$\begingroup$

Rendering seems to have a high toll on my computer. I render with my gpu but it is my cpu that overheats. I guess the cpu is conected someway even though i dont know in what way. So i wonder if there is a way to limit how many cores is being used when blender renders? Is there something else i can do, the more i can do the more potential to reduce the temperature there is.

I havent tried anything because i dont know what to try!

$\endgroup$
3
  • 1
    $\begingroup$ Hello :). There's a whole thread about limiting the resources given to Blender if that's what you want to do. $\endgroup$ – Jachym Michal Feb 16 '20 at 11:34
  • $\begingroup$ I will check it out, thanks. $\endgroup$ – Morten Fjellheim Feb 16 '20 at 11:35
  • 2
    $\begingroup$ Just that i have mentioned it, a pc should never overheat, even when running at 100%. When you have a heat problem then you should check your cooling system. Maybe buy better fans, or add one more. A quick way to fix heat problems would be to open the pc case ... $\endgroup$ – Tiles Oct 28 '20 at 12:43
0
$\begingroup$

There is an addon known as auto tile size which comes with blender you just have to enable it in blender user preferences you can limit how many cores are used for rendering and it also offers advance sizing options.
If still this doesn't works you may reduce voltage given to your cpu and limit its rpm speed in your computer's bios

$\endgroup$
4
  • $\begingroup$ Just to clarufy, i use my gpu for rendering so for that to help i would probably need to set the rendering to cpu. Why my cpu is overheating i dont know, but it seems like it is doing something in the rendering process. $\endgroup$ – Morten Fjellheim Feb 16 '20 at 11:46
  • $\begingroup$ By the way this addon also works with a gpu, but in the case you must limit your CPUs rpm speed using your computer's bios. $\endgroup$ – A D Feb 16 '20 at 11:50
  • $\begingroup$ Doing that will reduce the overall speed and will slow programs and games down that doesnt cause overheating. Is there a way to make this apply to blender only? $\endgroup$ – Morten Fjellheim Feb 16 '20 at 12:11
  • $\begingroup$ Your add worked actually. It appears that i put the settings too high the first time. $\endgroup$ – Morten Fjellheim Feb 16 '20 at 14:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.