0
$\begingroup$

I am following the RPG graphics tutorial to learn how to rig and animate a body(Although I am following on blender 2.8). Everything has been going fine up until the weight painting. Now, the weight painting works fine if I don't modify the pose in any way. But if I do pose the model and try to paint, blender acts as if I didn't modify the pose at all. I can have both arms up in the air, but I will have to paint as if the model is in the resting position. Does anyone know what can be causing this?

The tutorial

Blend File

$\endgroup$
0
$\begingroup$

The good news is your .blend file is fine. I had no trouble weight painting after changing the pose.

If, by any chance you didn't upload your latest version of your project, please make sure Pose Position is enabled, the Armature Modifier is turned on in the Modifier Tab and remove all keyframes or set keyframes for the current pose on the current frame.

I hope this was helpful to you.

On a side note: you should switch the Shading from Look Dev to Solid in Weight Paint Mode, otherwise the textures will make it harder to see the colors from your Weight Paint.

Weight Paint Pose Position

| improve this answer | |
$\endgroup$
  • $\begingroup$ This is really strange because you are the second person to say it works fine. It is the latest version of my blend that I sent and for some reason it's just not working for me. $\endgroup$ – A. White Feb 16 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.