I am following the trusty old donut tutorial by Blender Guru, and I have run into an issue.

I am up to part 6, first render. The camera perspective in layout mode does not represent the render output. When I view the camera perspective in any other modes, e.g. Sculpting, the render does in fact represent the camera perspective.

What have I tried?
1. Restarting Blender
2. Load Factory Settings
3. Deleted the camera and created a new one

When I alter the camera angle, the camera angle changes in the layout mode (and all other modes), but the camera perspective in the layout mode is still different to the render output.

What is going on within layout? I am so confused.

Layout Mode

Sculpting Mode

Final Render

  • 2
    $\begingroup$ Try 0 on the numpad to switch into the camera view (in layout and all other workspaces) or View > Cameras > Active Camera in header menu of the 3d viewport. $\endgroup$ – brockmann Feb 15 '20 at 12:44
  • $\begingroup$ @brockmann That's just basic navigation isn't it? I've tried that. I've also tried selecting the camera and pressing CTRL+0 to assign it as the active camera. $\endgroup$ – MikeBk Feb 15 '20 at 13:54
  • $\begingroup$ That looks more like you've zoomed in /panned into the camera view. Have you tried scrolling or Shift+MMB? $\endgroup$ – stphnl329 Feb 15 '20 at 20:21

You appear zoomed-in. Even though you have selected the camera view, it will retain the last zoom selected. Each workspace will retain it's own zoom levels. Just zoom out and hopefully that will resolve it. Oh and turn off Lock Camera To View as this sometimes confuses things. Once re-orientated, you can turn it back on.

  • 1
    $\begingroup$ Good idea @Derrick $\endgroup$ – brockmann Feb 15 '20 at 14:06
  • $\begingroup$ Thanks. Zoom was the issue. I expected zoom in and out (scrolling) would affect the camera position. However, when you think about it, the focal length is 50mm (it is a fixed focal length, not varying; e.g. 50-100mm). So zooming just zooms the view port, not the camera focal length. I should have pressed "G" to reposition the camera. $\endgroup$ – MikeBk Feb 19 '20 at 4:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.