0
$\begingroup$

To preface I am reasonably new to Blender, however recently upon trying to render a scene (which I have done perfectly fine multiple times before, even with the same file) Blender has now decided to crash as soon as it finishes rendering the first frame. This scene does have 13 particles systems, if that even matters, but I rendered it a few days ago with a majority of those and it exported perfectly.

I've ran the command line render, and it stops after two frames with: Error : EXCEPTION_INT_DIVIDE_BY_ZERO Address : 0x00007FF79C140EA2 Module : C:\Program Files\Blender Foundation\Blender 2.81\blender.exe

I can't find anything pointing to how I could fix this online, so I figured I would ask here.

I am running Eevee in Blender 2.81, with my export settings set to ffmpeg, MP4, H.264 encoding, and audio with MP3.

Any help would be greatly appreciated.

$\endgroup$
  • $\begingroup$ Since the issue is pointed to a specific blend file, I would start with deleting objects from a scene and confirm by render if issue persist. Like that you can hunt the problem. (You can start to delete all from scene and add only a Cube to see if its caused by render setup, if not the case - its some object, so start with deleting half objects at once. If OK issue lies somewhere in deleted part, if persists delete another half, and so on ... or start with deleting particle systems if you think its there. $\endgroup$ – vklidu Feb 15 at 8:56
  • $\begingroup$ It would be great if you could create a bug report through Help > Report a Bug in Blender and attach the .blend file to the bug report, ideally in a stripped down version that still causes the crash. If the file itself isn't corrupt, it's almost certainly a bug in Blender. The exception says that there is a division by zero happening which isn't properly handled. $\endgroup$ – Robert Gützkow Feb 15 at 10:28
1
$\begingroup$

Found what was going on. Needed to bake the animations for each of the particles systems.

I am unsure if this is something you are supposed to do when using particle systems, but I had not baked any of them to memory, and considering the render had worked before with fewer systems, I figured it wouldn't be necessary. Ran the render after baking each of them and it worked as expected.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you for sharing information :) $\endgroup$ – user2824371 Mar 18 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.