1
$\begingroup$

I'm new here so I don't know if I'm making this question in the right place, but I'm having an issue with bones in Pose mode and would be so thankful if anyone could help.

I can select them without any trouble in Edit and Object mode, but whenever I move to Pose mode I can't select them anymore. I could select them on the Outliner, but that isn't very practical nor intuitive.

Also, whenever I do select the intended bone, I get no outlines, just a very faint coloring on the object. That gets really confusing when I'm using bendy bone segments, as I can't tell whether they are there or not in side and front views.

I'm on Blender 2.82.7

I tried uninstalling and reinstalling the latest version, updating my drivers, but nothing has worked so far.

Sumarized:

  • I can't select individual bones in pose mode unless it's from the outliner

  • Whenever I can select the bones, I can't see their outlines

enter image description here

$\endgroup$
2
  • $\begingroup$ Happened to me as well. Probably a bug. I cant use select or box select but laso and circle select works, its annoying as hell. $\endgroup$
    – Fowl
    Feb 24, 2020 at 8:10
  • $\begingroup$ I am experiencing the same issue. My workaround for now is to use shift-select and box select. $\endgroup$ Aug 1, 2021 at 2:11

3 Answers 3

2
$\begingroup$

I had this exact same problem when trying to bring an armature from 2.8 into 2.79, and I found a solution that worked in that case, so maybe it will work for you as well. Try the following:

Create a new additional armature with a single bone in your project file. Then in Object mode, select your problematic armature (the one you can't select bones from in pose mode), shift-select your new single bone armature, and join the two (ctrl-j).

When I did this I was able to select all of my original bones in pose mode again.

$\endgroup$
1
  • 1
    $\begingroup$ Hey waruta! It doesn't seem to be working, but it got me thinking that maybe the problem was in the file itself. I appended the model and armature onto a new file and so far I can select the bones from pose mode (!!!) though it has worked briefly in the past and then stopped working. Hoping that won't happen again. Still no outlines, but this is a huge improvement! Thanks a lot for the idea and trying to help! $\endgroup$
    – Galowglas
    Feb 15, 2020 at 15:32
1
$\begingroup$

I've got the same problem and realized that it was because a saved the file with armature in Pose mode. If I save in object mode, all goes prety well. Must be a bug,to be solved in 2.83.

$\endgroup$
0
$\begingroup$

I was experiencing some of these symptoms and jumped to the conclusion that I was experiencing a potential bug; later, I found that in my case it was due to a simpler cause -- and giving a simpler solution. If you are experiencing this issue, it can help to rule out the simpler cause first.

In my case, the symptoms I was experiencing were due to my accidentally toggling Tweak/Cursor mode.

The following is demonstrated using version 2.91.0

Suppose your workspace appears like the following: Tweak/Cursor mode menu hidden

First open up the menu that exposes the Tweak/Cursor mode setting:

Tweak/Cursor mode menu displayed

In my case, I achieved this by dragging from the left edge of the workspace window.

Opening it a bit further helps illustrate it better:

Tweak/Cursor mode menu expanded further

Here is what it looks like for me when I hover over the Tweak mode setting, showing the shortcut that enters me into Tweak mode.

My Tweak mode shortcut setting

And here is what that looks like when hovering over the Cursor mode setting:

My Cursor mode shortcut setting

When I'm stepping through an animation using Shift-Space it is easy for me to accidentally toggle into Cursor mode, for which the shortcut is Space-Space.

When I'm in Cursor mode, I can select the first bone using Shift-Select but not Select. When I'm in Tweak mode, I can select the first bone using Select.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.