1
$\begingroup$

When I use the Track To constraint, my object snaps out of the original position and doesn’t track on the direction I want it to. How can I fix this?


before adding the tract to constraint, the body of the link rod is connected to the fuselage.enter image description here


after adding the tract to constraint, the body of the link rod is disconnects from the fuselage to a different position.enter image description here

$\endgroup$
3
  • 1
    $\begingroup$ Play with the "To" and "Up" axes, what works most of the time for me is "To" : "-Z" and "Up" : "Y" $\endgroup$
    – Gorgious
    Commented Feb 14, 2020 at 12:49
  • 1
    $\begingroup$ Before doing that, it can be useful to display the local axis of your objects. In Object Properties, under Viewport Display, tick Axis. $\endgroup$
    – thibsert
    Commented Feb 14, 2020 at 14:55
  • 2
    $\begingroup$ Hi. I suggest adding some before/after images to your post to illustrate your point. $\endgroup$ Commented Feb 14, 2020 at 18:43

1 Answer 1

0
$\begingroup$

This is probably long since answered, but (using Blender 3.0), the issue for me was setting the "Track Axis" properly in the bone constraint, as well as setting the Head/Tail tracking option to the one you want.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .