2
$\begingroup$

I am playing with rigid bodies in 2.79 and I'm having the following problem.

I have subdivided a plane a few times, then added subsurface and displace modifiers. I animated the displacement with a cloud texture and an animated null. A rigid body physic was also added to the plane (with 'passive', 'animated', 'mesh', and 'deforming' selected).

This creates an animated pseudo ocean surface.

I then add a few icospheres in the scene, on top of the plane. They are simply active rigid bodies.

When I do the Free Bake of the Rigid Bodies, the Icospheres instead of interacting with the animated and displaced plane, they simply rest on the original flat plane.

Am I doing something wrong or displaced animated objects cannot be rigid bodies in Blender?

Many thanks for any comment and advice.

enter image description here

enter image description here

enter image description here

$\endgroup$
  • 1
    $\begingroup$ You will have to apply all the modifiers in order to achieve this $\endgroup$ – A D Feb 15 at 15:07
  • 1
    $\begingroup$ Try switching source type from Deform to Final for displaced mesh in physics settings $\endgroup$ – Serge L Feb 16 at 8:15
  • 1
    $\begingroup$ Just an idea. Not tested. What if you use a collision plane with Shrink Wrap on top of the displaced plane? $\endgroup$ – LeoNas Feb 17 at 14:10
0
$\begingroup$

many thanks for your help.

I actually did it in an indirect way, a few days ago, by using arrays of passive/animated rigid bodies and connecting them to the animated plane by using Shrink Wrap. This created a moving floor (up-down motion), that interacted with the active/rigid icospheres, giving the result I wanted. Many thanks for your help and I will try the suggested methods to see if they work too.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.