0
$\begingroup$

fist things first I'm using Blender 2.81a and Unreal Engine 2.24.2 as well as the 1.0(beta?) of the gltf importer plugin in Unreal.

When importing the gltf file unreal strait up refuses to import animations because of "invalid joint weights". Mesh and materials are imported just fine: enter image description here

When importing the fbx file with these settings: enter image description here

The import seems to work fine, but the imported animations are empty at first sight: enter image description here

If you look closer you may see a tiny cube at the bottom of the thumbnail. So the animation somehow scales the imported mesh way down. Does anybody know what to do? The mesh itself does have the correct scaling just the animations are messed up.

All the files used in this example can be found here: https://drive.google.com/drive/folders/1q1PBeQfHW_PPNW9b7DyK5Jiivc9sFvms?usp=sharing

I found out that the scaling problem does direct relate to the apply scaling export settings in blender:

enter image description here

However no matter which settings I choose, I won't get a result in which the scaling is correct. Any idea if this is a Blender or Unreal Problem?

Thank you guys.

Cheers Edregol

$\endgroup$
  • 1
    $\begingroup$ The link is wrong. $\endgroup$ – FFeller Feb 13 at 18:20
1
$\begingroup$

I've managed to solve the issue over at the Unreal forum.

I did add a simple Armature and did not change the default name. That was the problem.

Change that name to anything but "Armature" and everything works fine.

| improve this answer | |
$\endgroup$
  • $\begingroup$ If you want to share a .blend file please use blend-exchange and not google drive. Please read this to learn how you could help us to give good answers. $\endgroup$ – metaphor_set Feb 17 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.