2
$\begingroup$

I have spent hours figuring out how to do this piece of my object. Starting over with a new mesh a number of times. I punched the holes manually, after learning the evil that is boolean modifiers. But I just can't seem to shake my bad luck with this piece!

Many artifacts show in render, but in render preview it looks nearly flawless. I don't have the option to leave out smoothing..it looks too poly without it. I have no idea how to fix this. Here is the rendered version: Render 1 Also notice how the metallic piece to the right (up against the glass) renders just fine, despite the fact that it is made with the same material.

Here is how it looks in render preview: Render Preview

The mesh in edit mode: Mesh - Edit Mode

Here is a link to my blender file for you to go nuts with: https://www.dropbox.com/s/9lh6z9hyeqwneqn/sonicpublic.blend?dl=0

$\endgroup$
2
$\begingroup$

You have a duplicate of the cylinder with holes object called Circle.002 which is hidden in the viewport, but not in the render. If you enable it in the viewport, the effect becomes obvious:

enter image description here


Also I'm pretty sure you don't need so much subsurf. Usually I don't use more than two subdivisions, sometimes three.

With all objects set to one level of subsurf, your scene renders in about 2:48 for me.

enter image description here

With the original subsurf settings, it renders in 3:50.

enter image description here

The visual difference seems pretty negligible, but there is change some of the lighting/camera angle in between tests because I stupidly did the 1 subd test first, then had to reload the scene to get the original subserf levels..


There are also quite a few ngons (faces made up of more than 4 vertices). These usually don't play well with subsurf, and cause some distortion. Here is an example screenshot of some ngons (subsurf is disabled in the screenshot):

enter image description here


I also noticed that you are getting a lot of noise from the environment texture. Enabling Multiple importance sampling in the world settings should help reduce that:

enter image description here

$\endgroup$
  • 2
    $\begingroup$ Oh my god. You sir, are a blender render bender. $\endgroup$ – Kittenmittons Oct 11 '14 at 0:11
  • $\begingroup$ unfortunately I am aware of those multiple vertices, but they do have some effect on the way the mesh is shaped since they pull inwards at differing amounts. I have attempted to dissolve them but it didn't turn out well... $\endgroup$ – Kittenmittons Oct 11 '14 at 0:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.