1
$\begingroup$

My task is to import a closed mesh into Blender, apply Bisect with the fill option, with the desired result being that the new body would also be a complete mesh.

However, the result I get has the bisect face filled with "grey", but no mesh. And an STL exported from that is similarly missing triangles in that area.

Example: Starting STL, a cylindrical cup, imported into Blender:

Cylindrical cup mesh

After applying the bisect tool along a horizontal line (ie: a horizontal plane):

After bisecting

As can be seen, the face that was cut has no triangles. And if exported to STL, that area is missing, with the overall shape not being closed.

Have I missed some option in bisect that properly fills in the mesh? Is there some subsequent step that's needed?

$\endgroup$
2
$\begingroup$

The "Bisect" function did generate a surface at the cut area, though it's an N-gon, STL-export seems to not offer an option to triangulate N-gons automatically.

Solution:

You can select the cut surface in Edit mode with Face selection and then use "Triangulate Faces" in the "Face" Menu Ctrl+F. Or use the direct shortcut, in this case Ctrl+T.

Here an example:

Similar object bisected and then triangulated

This should do the trick.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.