5
$\begingroup$

This particle system with Molecular Add-on blows up even though there seems to be more than enough space between the particles. Any idea why is this happening? I'm using Blender v2.81.16.

Here is the file

Frame 1:

frame 1

Frame 2:

enter image description here

Particle System rendering settings:

enter image description here

$\endgroup$
  • $\begingroup$ Can you add your particle system setting? I just get the baked animation, but unless I can reproduce it, I can't fix it $\endgroup$ – WhatAMesh Feb 13 at 19:25
  • $\begingroup$ Have you tried the attached .blend file? $\endgroup$ – user1566515 Feb 13 at 19:34
  • $\begingroup$ is your object a collision object? $\endgroup$ – J Block Feb 13 at 19:52
  • $\begingroup$ @user1566515 Yes of couse $\endgroup$ – WhatAMesh Feb 13 at 19:54
  • $\begingroup$ @WhatAMesh Do you need any additional info? $\endgroup$ – user1566515 Feb 13 at 20:19
3
+50
$\begingroup$

Issue comes from particles self collision (so boundaries). In your case if you Display as Circles, you can see they are overlapping, set Render size to 0.02. Particles stops to explode.


  • To see particle's collision boundaries switch Viewport display > Display as Rendered to Circle.
  • Adjust Size value, so circles doesn't overlap.
  • The same value set in Render > Render as Object > Scale panel.
  • Then you can switch back Display > Display as Rendered.
  • Scale object (Sphere) in 3Dview (Object or Edit mode) to desired size.

What matters - Render Scale (viewport size is only for reference)

What confuse - Object Scale in 3D view does not affect self collision

The goal is to keep not overlapped "Display as Circles" with the same value for "Render as Object" ... Than if you scale object (Sphere) in 3Dview via Object mode or Edit mode doesn't matter. A size of object doesn't matter here, object can overlap each other or be a micro, its size doesn't affect behaviour of particles.

Render Scale 0.05 enter image description here

Render Scale 0.1 enter image description here enter image description here

enter image description here

To see real boundary with Rendered as Object - add a new Sphere (by default Scale 1 / Dimension 2) and set Render Scale to 0.02, same set for selected Sphere in 3Dview Properties > Item > Transform > Scale. To see it right, uncheck in Particles Properties > Render > Object > Object Scale. Now you can change only Render Scale value and have a control over real boundary at the same time (don't change Scale in 3D view from now).

enter image description here enter image description here

Note: Oject Scale means - use object scale value on top of particle scale. If particle will be size 2 and object scale 0.5 rendered particle (Sphere) will be size 1, but size of collision boundary stay 2. And "Render Scale" value matters :)

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Thank you for shedding some light on this unnecessarily confusing situation :) In your answer, when you say " Render size" do you mean " Render > scale"? I'm not sure if it's different for different versions, but as of v2.81, there's no " Render size". $\endgroup$ – user1566515 Feb 14 at 18:34
  • $\begingroup$ So the bottom line is that Molecular Script uses one and only one setting to calculate collisions between particles and that is Render>Scale value which it treats simply as particle size. Correct? $\endgroup$ – user1566515 Feb 18 at 15:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.