1
$\begingroup$

I am trying to render this image with transparent background, but instead it renders as blue. I have checked the world settings, HDRI. The problem only happens in render and not view port. Problem persist in both eevee and cycles. Any help is appreciated.enter image description here

$\endgroup$
3
$\begingroup$

You're compositing the blue background in. Enter the compositor and either mute the Mix node or remove it.

enter image description here

$\endgroup$
  • $\begingroup$ Why does using the Alpha create that thin, blue line? I imagined to be proper about things, the Alpha socket could be filled but its result isn't as clean as omitting the Mix Node. Shouldn't it be pixel perfect? $\endgroup$ – HelloHiHola Feb 8 at 20:52
  • $\begingroup$ @HelloHiHola What thin blue line are you talking about? $\endgroup$ – Electric_Wizard Feb 8 at 21:06
  • $\begingroup$ Can't add pictures here but if you drag the Render Layers Alpha into the Composite Alpha socket (looking in Compositor), the results aren't as clean as I would expect. I was curious if you knew why since that seems a formal option of eliminating the blue. $\endgroup$ – HelloHiHola Feb 8 at 23:24
  • $\begingroup$ What you're seeing is the background peeking through the non-100% black of the alpha channel due to antialiasing. Create a Viewer node in the compositor and plug the Alpha into the image input and zoom in to the image - you'll see grey pixels between the white and black. Wherever it's grey, that's where you see some blue peek through. To remove this completely you can put a Luminance Key node with high and low set to 1 between the alpha out of the image and the alpha in of the viewer/composite node. $\endgroup$ – Electric_Wizard Feb 9 at 0:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.