6
$\begingroup$

I only want to be able to select vertices that are on faces facing me, but I frequently select vertices that are on the other side of the mesh. It's a bit annoying as far as workflow. I know about the limit selection to visible button, but that's not what I'm referring to. Is there a solution?

Here is an example. Though even when the mesh is closed, blender will snap onto vertices from the other side.

enter image description here

$\endgroup$
  • 4
    $\begingroup$ Can you explain how 'Limit selection to visible' isn't doing what you want? Not selecting vertices on the back of a mesh is exactly what that option is for. $\endgroup$ – Ray Mairlot Oct 9 '14 at 17:47
  • 1
    $\begingroup$ I will add a picture to clarify. I don't want to be able to select the vertices circled. $\endgroup$ – KoolMode Oct 9 '14 at 17:51
  • $\begingroup$ Please explain what vertices you do want selected then. $\endgroup$ – Scalia Oct 10 '14 at 20:37
3
$\begingroup$

The closest thing would be to select one vertex of a backface and select similar vertices Shift-G Normal adjust the threshold in the last operator panel (Left to the viewport if not visible toggle with T)

enter image description here

and hide the selection H, after editing unhide Alt-H.

Note: Hiding backfaces would only prevent Blender from filling them, all vertices,edges will still be selectable in Edit Mode: enter image description here

$\endgroup$
  • $\begingroup$ To me this is not a solution as when you edit a mesh, you have to move your camera around, so repeating this task every time you move it is just out of question for me who tend to move it quite a lot. $\endgroup$ – ChameleonScales Feb 1 '17 at 22:51
2
$\begingroup$

I have encountered the same issue as Koolmode. It is also a problem with face and edge selection, with or without overlays.

The following does NOT correct the issue (for me):

  • Backface culling (3D viewport, shading panel)
  • Limit Selection to Visible (3D viewport, header bar)
  • increasing minimum or decreasing maximum viewport clip (shading panel)
  • both 'multitexture' and 'GLSL' display styles (3D viewport, shading panel)
  • Any combination of selections/values in 'system', 'editing', or 'input' screens of user preferences (as far as I could tell)
  • Separate object, deselected, placed inside the object being edited so as to provide an extra barrier.

  • With 'Limit Selection to Visible' enabled, a rear vertex will not be selected if it is either behind a face in the currently selected mesh or perfectly in line with (and behind) a vertex (only really applicable with precision modeling in 2D orthographic). A vertex behind an edge and at the edge of a mesh can still be selected.

Two workarounds: 1) As mentioned above, hide vertices you aren't trying to edit; masking will do the same thing, but this would be pretty tedious. 2) Add a large plane to the currently selected mesh, its face normal facing you, and use it to hide meshes.

It would be wonderful if this issue were fixed! I don't know the first thing about Python or C, but I'll give it a go and see if I can figure something out.

$\endgroup$
1
$\begingroup$

You can use View > Clipping Border... (Alt + B) to show only the vertex you want to deal with.

Once you set the clipping border, you can use any selection tool (lazo, circle, border) and the hidden vertices will be ignored.

CAVEAT: If you select all (A), the selection will be extended to the hidden vertices.

View Clipping Border

$\endgroup$
  • $\begingroup$ This should be the accepted answer. $\endgroup$ – Stabledog Sep 29 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.