1
$\begingroup$

Even though my settings are set to use the GTX1070, my CPU activity is still 100% while rendering. Can anyone explain how this comes, and/or tell me how to fix this so Blender will (almost solely) use the GPU? I'm using the Cycles render engine with a material defined by image maps and Principled shaders.

Thanks in advance Task Manager overview Blender Settings

$\endgroup$
1
  • 2
    $\begingroup$ You have your i5 CPU selected in the CUDA tab, which enables GPU+CPU rendering. $\endgroup$ Commented Feb 7, 2020 at 15:41

2 Answers 2

2
$\begingroup$

As @RobertGützkow already mentioned in the comment, you have not only selected your GPU for rendering, BUT also the CPU.

Selecting GPU Compute makes Blender render with all selected devices to speed up the entire procedure, while sometimes it is faster, it may even be slower, depending on the render and the devices as well as the render performance settings like bucket-sizes.

If you only select the GPU, as in un-check the CPU, Blender will render only on the GPU, but even then Blender needs to prepare some things beforehand and will use your CPU a little. After which the CPU should be left rather idle compared to what you experienced.

The Solution thus would be to make sure to not have the CPU selected in the render device settings.

Maybe it could be reasonable to change the GPU Compute to Compute on all selected Devices well a shorter name could be helpful, but i believe that you get the point.

$\endgroup$
1
  • $\begingroup$ I'll try that, thank you $\endgroup$
    – Jonas
    Commented Feb 8, 2020 at 17:16
1
$\begingroup$

Some processes have to be done by the cpu. At the latest if it comes to filling out the quads with picture while rendering your gpu should start working.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .