0
$\begingroup$

I've been building a low-poly planet but for some reason when I hit render one of my objects is not visible. I have tried everything I can think of but nothing seems to make the object appear in my render.

Tried adding a new camera, tried the 'clear restricted render' but I'm using mac and I can't get the prompt to show - unsure what shortcut/key it is on mac?

If it is somehow relevant after I've clicked render and go to the compositing view I cannot see ANY nodes, completely blank.

enter image description here

$\endgroup$
  • $\begingroup$ Welcome to Blender Stack exchange Community! Can you please upload the blend file? $\endgroup$ – Harshvardhan Rajpurohit Feb 7 at 13:25
  • 1
    $\begingroup$ Which answers you have tried already? $\endgroup$ – brockmann Feb 7 at 13:43
  • $\begingroup$ It looks like you have a particle emitter on your object. Have you checked to make sure "Show Emitter" is enabled? See this post and answer below: blender.stackexchange.com/questions/129173/… $\endgroup$ – crazycourier Feb 7 at 17:03
  • $\begingroup$ I know it has been closed, but don't be scared of sharing the blend file. I have found that there are quite a few little gotchas that whilst not obvious to you, it can quickly be seen by fresh eyes. This is a very generous community and will help if they can. $\endgroup$ – Derrick Feb 8 at 13:14
0
$\begingroup$

you can check if relevant objects are enabled/disabled in render. I usually prefer to show it in outliner like this:

  • click on filter icon and activate the button with camera icon

enter image description here

  • then you can see it in outliner and check if object is enabled/disabled for rendering

enter image description here

and since you are using modifiers you should check if render is enabled for modifier too (it is always the camera icon)

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for your response, the weirdest thing is I have the camera icon enabled and they are all enabled - it's the strangest thing. Even on my modifiers the camera icon is enabled. $\endgroup$ – jk_kidding Feb 7 at 14:13
0
$\begingroup$

Couple of options without seeing the file. Check the "disable in Render" filter is not selected. An example is attached where the cross indicates that it will not be rendered enter image description here

The next check is you mention that you go to the composition workspace. Have you checked the "Use Nodes" option, this is off by default and so nothing is visible.

Alternatively you could instead go to the Rendering workspace or under the Render menu click View Render (F11 in Windows)

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for your response mate, all the camera icons are enabled (even for modifiers), the 'use nodes' trick did work though, so thank you for that, but I'm afraid my object still won't render correctly! =( $\endgroup$ – jk_kidding Feb 7 at 14:14
0
$\begingroup$

Looks like you have a particle emitter on the earth object. Go to your particle settings and check to make sure "Show Emitter" is enabled. The screenshot below it's disabled so it wouldn't show in the final render (but it will show in the viewport render), make sure that box is checked.

enter image description here

| improve this answer | |
$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.