0
$\begingroup$

I want to rotate the house. When I rotate on the Z axis, only house frame moves as one object. Other house assembly remains (actually rotates on different origin? How to remedy?

enter image description here

$\endgroup$
  • $\begingroup$ Select all of the objects by pressing 'A', then rotate by pressing 'R' + 'Z'. $\endgroup$ – Nate_Sycro27 Feb 6 at 20:00
  • 1
    $\begingroup$ Can be caused by many things, rotation in individual origin mode , scale dimension, pareting, locked rot .... post blend is fastest way. $\endgroup$ – vklidu Feb 6 at 21:15
  • $\begingroup$ or dropbox.com/s/htakvyorgsaq4fn/… $\endgroup$ – NeverGiveUp Feb 6 at 23:10
  • 2
    $\begingroup$ Your transformation orientation is set to local. Set it to global (i.stack.imgur.com/qxLJW.png), make sure you only select the objects you really want to rotate (there also is a camera in the scene) and let's go rotate them @NeverGiveUp $\endgroup$ – brockmann Feb 6 at 23:35
  • $\begingroup$ @brockmann solved the issue, i.e., transformation set to global. tks. $\endgroup$ – NeverGiveUp Feb 7 at 15:21
2
$\begingroup$

Unable to load your Blend file (still operating on Vers 2.77a) and probably not seeing what your helpers are referring to.

Going on your pic and on the face of it, the problem you appear to be encountering, might well be solvable by simply parenting all components to the one common parent and moving/rotating that instead.

I see 'parenting' has been mentioned in the comments/answers but would this make it a little clearer? ...

By making every separate component a child of a common parent, using the parenting feature, (CTL-P) not the child-of constraint, that parent (the Circle-Empty) should "localise" and hold all the bits & pieces together, with respect to the Empty. (and the house)

It's the empty you move/rotate around the scene, not the house or it's components.

The house and components would be forced to move with the Parent-Empty and importantly, their relative positions are maintained with respect to the house.

Individual components can still be moved around, scaled etc without affecting the 'bond'.

I apologise if I'm barking up the wrong tree here, I cannot see the Blend file, but if it helps... If not, say so and I'll delete this.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Similarly by parenting objects to the house, or via some hierarchical logic with a common parent. $\endgroup$ – batFINGER Feb 7 at 8:18
0
$\begingroup$

Select all of the objects by pressing 'A', then rotate by pressing 'R' + 'Z' to rotate on the Z axis. If you want to reset the origin of the other house to the same as the first part you have rotated, then set the cursor to that part of the house, then select the other part you want to reset the origin on. Go to Objec > Transform > Origin to 3D Cursor. Now it will rotate on the same origin.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Using 2.81a, In Object Mode. Select all. I set origins > mass > center, to both "houses". Then went to Object >Transform >, but there is no "Origin to 3D cursor" at that point. When I rotate z axis, parts of the "2nd" house go flying. I get what you're teaching, but for some reason I can't select all. Happy so send a blend file, but not sure you get materials, etc. $\endgroup$ – NeverGiveUp Feb 6 at 20:36
  • $\begingroup$ Weird since in all Blender versions, there should be a Origin to 3D cursor. I do not know what version of Blender you are using, but there should be an "Origin to 3D cursor option. Try looking again in the transform tab, or look in the tabs around it. $\endgroup$ – Nate_Sycro27 Feb 6 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.