1
$\begingroup$

I am working on a space scene using a 3D model of a starbase that I downloaded online. There's a sun in the scene that illuminates the starbase. The starbase gets illuminated in Cycles, but when I switch to Eevee, it does not receive any light from the sun.

Comparison

The node tree of one of the "head" of the mushroom-shaped starbase looks like this: Node tree

Am I missing something fundamental that you more seasoned pretzels can see at the first glance?

$\endgroup$
  • $\begingroup$ Have you tried to bake indirect light? Maybe placing a reflection cubemap around the spaceship? $\endgroup$ – joaulo Feb 6 at 20:27
  • $\begingroup$ it should work, as the directional light is no material emission or primarily indirect. Maby its something else? Could you upload a file? $\endgroup$ – A M Feb 6 at 21:04
  • $\begingroup$ Sure - here it is: 1drv.ms/u/s!AohDmDW98tXLg91V8xNw6WMVLYj1Ng?e=I4ZhUl Many thanks! $\endgroup$ – Ondrej Feb 6 at 21:14
  • $\begingroup$ @AM, did you have a chance to take a look? $\endgroup$ – Ondrej Feb 13 at 17:37
  • 1
    $\begingroup$ sry tried to take a look, but the file is pretty complicated (many small nested parts) and i dont have much time at the moment. What i found was that there are countless lamps inside the station. Also copying the hole station to a fresh blend-file brings the error along, copying single elements doesnt. Maby this way you could narrow it down, which object causes this behavior. $\endgroup$ – A M Feb 13 at 18:39
2
$\begingroup$

I could narrow it down to the huge number of lights (134) in the scene. Deleting all lights and adding a fresh sun restores the display of shadows. By using the new filtering parameters, lights can easily be found:

It looks like that eevee cant handle that many lights and additional ones will simply be ignored: https://docs.blender.org/manual/en/latest/render/eevee/limitations.html

enter image description here

unfortunately

| improve this answer | |
$\endgroup$
  • $\begingroup$ Very interesting. Not what I expected, but it seems to be the right answer. Thank you! $\endgroup$ – Ondrej Feb 14 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.