3
$\begingroup$

My laptop seems to be rendering infinitely faster whilst charging then it does when it's not charging for some reason.

My setup is an i7 9th gen w/ an RTX 2060. I'm rendering using OptiX.

As can be seen in the below image, it finishes rendering in less than a minute while charging:

while charging

However, when it is plugged out, as can be seen below, even after a full minute, it hasn't even finished half of the image.

while unplugged

I tried rendering with the processor when my laptop was unplugged, and even that finished faster than the graphics card while it was unplugged! And this isn't just the case with rendering. It's just faster overall when charging, period.

Why is this happening and how can I stop it? Many times, I need to render while the laptop is unplugged, and so it is imperative that this issue is solved. Thanks.

$\endgroup$
  • 10
    $\begingroup$ Probably this depends on the operating system. You are supposed to look for the solution in the Control Panel>>Power Management or in the Graphic Card's software. $\endgroup$ – FFeller Feb 6 at 18:29
0
$\begingroup$

Your issue lies in power management.

Your operating system (Windows 10) is currently instructed to limit performance of your CPU and GPU and in order to save power and extend battery life and longevity.

It sucks.

How to fix it:

  1. Navigate your way to Control Panel
  2. Go to System and Security
  3. Go to Power Options
  4. Go to Change Plan Settings
  5. Choose Advanced Power Settings
  6. Verify that minimum processor state and maximum processor state are set to 100% all the time
  7. Set cooling policy to active
  8. Disable PCI Link State Power Management

I don't have Nvidia graphics, so I can only assume there is a power management section in the NVidia Geforce Experience or something

  1. Since you're on a laptop, you should also buff up your integrated graphics as the data from your 2060 may or may not be passed through the integrated graphics card.

  2. Follow the BlenderGuru's advice to speeding up Cycles rendering in general. https://www.youtube.com/watch?v=8gSyEpt4-60

  3. Update your drivers if needed.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for your answer. For some reason, I only have five options in my advanced power settings: Desktop background settings, Sleep, Power buttons and lid, Display, and Battery, which, for the record, only has options on when to give notifications such as critical battery level and stuff. Do you know why I don't have the other options? $\endgroup$ – Arihan Sharma Jun 10 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.