1
$\begingroup$

I have problem with my project when i import a 3D world inside blender it be normal the texture good and clear but when i run the game it be like this:

enter image description here

Normal view:

enter image description here

If someone can help me i will be thankful :)

$\endgroup$
  • $\begingroup$ Seems like your models have inverted normals and the get removed through backface culling when using the game engine. $\endgroup$ – Robert Gützkow Feb 6 at 14:46
0
$\begingroup$

There are a few things that could be causing this.

First, backface culling

That happens because the inside of the mesh are backfaces and somewhere, (in the object data panel or in the materials panel in the properties menu) there is a checkbox for backface culling that is set to true. If you turn it off, then the backs of the faces will no longer show through.

Second, Your camera/viewport could be inside the mesh a little bit.

Third, your normals could be off in some way. Go into edit mode, select everything, and "recalculate normals." you can find this command by pressing the space bar and typing 'normal' until the command comes up (if you are using 2.79 controls) or by pressing f3 (if you are using 2.8 controls)

| improve this answer | |
$\endgroup$
  • $\begingroup$ The methods did not work with me. Some distant faces appear above the nearby faces, such as the ones in the picture. Could the world have a problem with texture or something? $\endgroup$ – Mantaloga Feb 7 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.