0
$\begingroup$

I'm pretty new to Blender, been using it only the last two days, mostly doing 3D modeling until now and UV mapping. I've UV mapped the front and side of my model in different UV layers and I have a third one in which I will clone from the first two, front and side. It was a pain to figure out most of the stuff, seeing as most of the tutorials are old and even the newest ones don't have the same interface as Blender 2.72.

Now here lies the problem, I barely found out how to clone from layer to layer, the old option in the project paint is gone, I have no clone from option. What I did is checked the option to clone from paint slot in the F Clone brush and then set up the source (UV layer, Image). The thing is it works fine, it does what it is supposed to do, but whenever I click to texture via brush, it doesnt apply to the faces the brush is on, but to the ones on the back, so I have to colour the back in order to get the front and viceversa.

I'm running Blender 2.72 x64 on Win8.1u1 x64.

I gave up seeing as it isn't the way it should be done and came here for help. Can you please tell me what I am doing wrong?

Heres my blender file (externals packed)

$\endgroup$
1
$\begingroup$

After looking at your mesh for a few minutes, I noticed the shading was a bit off. I recalculated the normals, and texture painting worked just fine.

Here is how it is done:

Go into edit mode and select everything. Then in the Tool Shelf go to the shading tab.

Then click the Recalculate Normals button.

normals

After doing this Texture Paint mode should work as expected!

One other thing that might help while Texture Painting is to re-unwrap your model. I noticed that the UV unwrapping was very messy and jumbled. If you don't know how, look into how to mark seams for your mesh so you can unwrap the whole mesh on one UV map with minimal stretching. That will allow for less visible seams and a smoother workflow while painting.

I hope this helps!

$\endgroup$
  • $\begingroup$ Thank you, thought I had already recalculated the normals, but I probably had forgotten, you are right about the unwrapping, I am going to improve upon it and definitely going to use the seams, but I wanted to get a working model first and then learn more about the whole process. Still I can't thank you enough! $\endgroup$ – Klint Mane Oct 9 '14 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.