2
$\begingroup$

I have 2 Nvidia GTX Titan Black graphics cards in my machine, but Blender keeps using only one of them.

I have them both checked in the Preferences > System > CUDA tab but when I render and take a look at the Windows performance screen only one of them is in use.

I´m using Windows 10 and blender 2.81, my graphics drivers are all updated. Anybody have any idea what the problem might be?

$\endgroup$
  • 2
    $\begingroup$ If you're using Eevee, multiple GPU rendering is not supported. $\endgroup$ – stphnl329 Feb 4 at 23:27
1
$\begingroup$

I had a similar problem a while back with cycles. I used a script for rendering on remote ubuntu systems with titans xps. Try running the following script IF you too have Titan xps, otherwise try to find the right blender-name for your GPU first. This may or may not work, I thought you may want to give it a shot.

import os, bpy

os.environ['CUDA_VISIBLE_DEVICES'] = '0,1'

bpy.context.scene.render.engine = 'CYCLES'
bpy.data.scenes["Scene"].cycles.device = 'GPU'
bpy.data.scenes["Scene"].cycles.feature_set = 'SUPPORTED'
bpy.context.preferences.addons['cycles'].preferences.compute_device_type = 'CUDA'

cprefs = bpy.context.preferences.addons['cycles'].preferences

# Enable all CPU and GPU devices
for device in cprefs.devices:
    if device.name == 'TITAN Xp':
        device.use = True
    else:
        device.use = False

# Tests
print('Compute_device_type: ', cprefs.compute_device_type)
for device in cprefs.devices:
    if device.use == True:
        print('USED: ', device.name)
    else:
        print('NOT_USED: ', device.name)
print('Will be used: ' + bpy.data.scenes["Scene"].cycles.device)
print('Feature set: ' + bpy.data.scenes["Scene"].cycles.feature_set)
print('Render engine: ' + bpy.context.scene.render.engine)
| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.