1
$\begingroup$

I'm trying to import a FBX file from Navisworks into Blender, but whenever I do I can't see anything. I can see something in the menu to the right under Scene Collection, but all I get are these lines. I'm new to Blender, if you couldn't tell.

blender problem fbx

Am I importing the fbx file wrong, or exporting it from Navisworks incorrectly? Is it maybe a problem in Navisworks? I have Blender version 2.81, and Navisworks Manage 2020.

$\endgroup$
1
  • 1
    $\begingroup$ The status Bar says that the Blender file has 99,697 faces. Can you upload a .blend file with similar issues? $\endgroup$
    – tetii
    Jul 10, 2020 at 7:29

2 Answers 2

3
$\begingroup$

If your scene was empty before the import, it looks like stuff is importing correctly as there are objects in your outliner. My guess is that the scale during import is off. The objects might be there, they're just scaled too big or too small to see. Try using the . key on the numberpad, which centers the view on the selected object.

You can also try re-importing, but in the import options start by changing the scale to 0.1 and if that doesn't work, try a larger number like 10.

You can also find some more info that might help here: how to scale imported .obj and .fbx

$\endgroup$
4
  • $\begingroup$ My scene wasn't empty, it's supposed to be a room with plumbing and electrical equipment. So maybe somehow those elements didn't convert? I tried adjusting the scaling, the only thing that happening was the lines grew.When I import the file and leave the initial cube that's there when you open a new scene, I notice that the orange icon next to the cube and the orange icons next to the other things like the heating hot water return pipes are different. The one next to the cube looks like an upside down triangle, and the other icons are either a camera or a vertex. Would that mean anything? $\endgroup$ Feb 4, 2020 at 21:56
  • $\begingroup$ Sorry, looking at the outliner in your scene and it looks like the import is reading your objects as "empties" and not actual mesh objects. I would go back into Navisworks and try tweaking your export settings from Navisworks. First start with the FBX File Version, try setting that to an older file version. Try also export with and without Polygon Limiting enabled. $\endgroup$
    – scottywood
    Feb 4, 2020 at 22:10
  • $\begingroup$ I've tried several different versions of fbx and with or without polygon limiting enabled. No idea why they still import as empties. I have posted a separate question as to why they are, thank you for your help. $\endgroup$ Feb 5, 2020 at 20:54
  • $\begingroup$ Have you tried importing the FBX into another 3d program? Something you might give a try is creating a simple single model in Navisworks and exporting that. If that works, then it's your Navisworks file, if it doesn't it could be a blender issue. You might also try using Blender 2.79 to do the import and see if you still have import issues through that version since 2.8+ is still under development. $\endgroup$
    – scottywood
    Feb 5, 2020 at 23:33
1
$\begingroup$

For other people still having this problem, check Layer Display Mode.

enter image description here

For me, fbx was being imported in the hidden layer. And I was in the Scenes display mode, where everything looked normal for some reason.

enter image description here

I just dragged those files from hidden layer to layers that are visible. I could make the hidden layer visible by enabling some things in the filter.

enter image description here

But in my case it contains auto-rig plugin bone graphics, witch are not ment to be visible like this.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.