3
$\begingroup$

I have implemented two identical particle emitters back to back so that i get a looping animation depicting low-poly smoke. I use a blend texture to resize the particles as they go through their life. I baked all dynamics using the button in the cache section of the simulation and everything loops nicely in the viewport.

The problem is that, although everything shows up correctly in the viewport, the particle system behaves weirdly for the last 60 frames or so of the animation when rendered. The smoke particles spawn more quickly and go through the resizing procedure dictated by the texture super fast, leaving the space empty.

Particles show up correctly in viewport.

As you can see the cursor is at frame 280 in the screenshot and both solid and rendered view show the smoke particles. When I render the image though, the result is this:

Final render shows weird particles.

I have tried following solutions without success:
- Use Cycles instead of Eevee
- Have the particles emit only in positive frame ranges as opposed to emitting from -300 to 300
- Following this tutorial for baking particles: How baking works on renderstreet
- restarting blender

.blend file with only the particle system:

$\endgroup$
  • $\begingroup$ I suggest upload a simplified file e.g. only the particles to blend-exchange.giantcowfilms.com so we can have a look... $\endgroup$ – brockmann Feb 1 at 19:23
  • $\begingroup$ Done. I noticed that when reopening the file, the problem actually occurs in the viewport. After deleting and re-baking the system, though, the viewport display is as expected, while the render still isn't. $\endgroup$ – flexomatico Feb 1 at 19:38
2
$\begingroup$

The viewport has still several update issues. Scrubbing the timeline back and forth and jumping to the first frame ShiftLeft Arrow can help forcing the viewport to update (sometimes).

To make sure the particles are rendering as expected I always enable Disk Cache and Bake all Dynamics (Particle Properties > Cache) before rendering, which works in this case too:

enter image description here
Frame 1-100

| improve this answer | |
$\endgroup$
  • $\begingroup$ Enabling the Disk Cache solved it, thanks! $\endgroup$ – flexomatico Feb 1 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.