I want to use Eevee to render my animation in Blender 2.81. The animation involves lights behind/inside objects with one side open. When I add a cube to the scene with a Principled Volume shader in order to see the lights, the light cone can be seen through the box. This is not a problem in Cycles, but due to the increased render-time and noise in Cycles, I'd like to render my animation in Eeve. Any help is appreciated.


Lights clipping in Eevee


Lights not clipping in Cycles

This is the cube/light:

Setup of the scene

  • $\begingroup$ having the same problem, trying to make a flash light $\endgroup$ Commented Mar 18, 2020 at 19:11

2 Answers 2


Seems like Eevee sometimes really has some troubles with volumetric lighting. As they say here: https://developer.blender.org/T71208

I think this was a side effect of a previous bug (in 2.80). basically, the volumes were all shifted 1 voxel further from the camera. This was fixed but now this light leaking is just a side effect of the volume texture being low res. There is little we can do to fix it. The workaround is to give more precision to the volume (increase samples in volumetric settings) and the shadow maps.

this is a sort of precision error. This probably won't be fixed anytime soon. Unless a new groundbreaking volumetric lighting approach is discovered, which is... quite unlikely? You can attempt to alleviate this by making the volumetric lighting texture more fine. This will however use more VRAM so be careful

I hope it will help.

These few quite similar cases may be helpful too:


This issue is still here in Blender 4.0. There is just one way I've found that works. First increase the Radius till it becomes barely visible, and then increase the Power.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .