2
$\begingroup$

i wanted to reflect the 3d model in mirror. i added a plane and i have increased metallic nature to 1 and decreased roughness to 0 but i have added a background image hdri before.so its reflecting the background image not the 3d model . so how can i get rid of this problem ? if i remove the background image hdri . its not reflecting anything at all
in top view i can see a little bit of reflection..

enter image description here

enter image description here

enter image description here

$\endgroup$
3
$\begingroup$

I assume you are using Eevee as it seems in the second screenshot. In Eevee to get better reflections you should use "Reflection Cubemaps" or "Reflection Planes". You can find them in "add menu" > "light probe". Since your mirror is a plane object I suggest you to put a reflection plane on the surface of the mirror. Here you can see the difference:

enter image description here

This is without reflection plane. And this is with a reflection plane on the surface of the mirror object:

enter image description here

HDRI image should not affect objects reflections, only background reflection.

You can read abount reflection cubemap/plane here: Blender 2.81 Manual - Eevee Light Probes

| improve this answer | |
$\endgroup$
  • $\begingroup$ Lol you probably posted your answer as I was writing mine... $\endgroup$ – Luciano Jan 31 at 14:54
3
$\begingroup$

You could use a reflection plane. I knew nothing about mirrors on Blender until I read your question. I did a quick setup and this is my result:

final result

You add the reflection plane probe surrounding the plane (Add > Light Probe > Reflection Plane ), pointing towards the direction of your reflection. The probe should surround the plane, and I positioned the center (reflection plane preview) slightly above my plane object.

These are the settings for the mirror plane material, nothing fancy:

material settings

And these are the settings for the Reflection Plane Probe:

probe settings

| improve this answer | |
$\endgroup$
  • $\begingroup$ NO I CANT FIND SOLUTION USING THESE TWO ANSWERS I NEED SOME ANTHER WAY $\endgroup$ – Dileep Kumar Deepu Jan 31 at 17:10
  • 1
    $\begingroup$ @DileepKumarDeepu 1: ALL CAPS is the written version of shouting thus considered rude; 2: this is a good solution (as you can see 2 users had the same idea to solve your problem). If it's not what you want please edit your question to add WHY you don't want to use Reflection Planes specifically, or just wait for other answers. Check How to Ask if you need more info. $\endgroup$ – Luciano Feb 3 at 8:49
  • $\begingroup$ I cant use reflection panel i dont know how to use that i have seen tutorial videos but its not working with my project $\endgroup$ – Dileep Kumar Deepu Feb 4 at 10:08
  • 2
    $\begingroup$ @DileepKumarDeepu You got 2 answers here explaining in detail how to add reflection planes, what part of it are you having trouble with? Perhaps you should try creating a new file and follow the steps and see where you get stuck, then come back and tell us so we can help. $\endgroup$ – Luciano Feb 4 at 10:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.