1
$\begingroup$

I can't seem to have my material turn transparent in blender 2.80. Heres some screenshots, is there something I'm missing?

This is how it looks in EEVEE:

material sample in EEVEE

Here is my node setup:

node setup

$\endgroup$
2
$\begingroup$

If you want to make the object transparent, their are 2 ways to do that:

  1. Use transparent material (as you have already used), Add it to a mix shader whith the respective shader you want it to mix with and change the blend mode for the object to "Alpha blend". Transparent-shader

Now, you use this method when you want to create an object with just transparency, that means without any reflection (that doesn't quite exists in real world). Every transparent material has refraction and if you want your material reflect like glass you can use the second method.

  1. Using a glass shader. It won't directly reflect the changes right away, you need to enable "Screen space Refraction" for both the scene and the material you. Then you need to change the refractive index of the material to the one you wish for, or just keep it anything else than 0. Glass-shader Scene settings to enable refractionScene-settings
$\endgroup$
  • $\begingroup$ Thank you for the help! $\endgroup$ – Juriaan Jan 30 at 14:06
  • $\begingroup$ Happy to help! :) $\endgroup$ – Harshvardhan Rajpurohit Jan 31 at 12:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.