When pressing I, I now receive:

keying set failed to insert any keyframes.

No idea why pressing I doesn't work anymore. What did I do wrong? (I've upgraded from 2.71 to 2.72 and it stops working).

  • $\begingroup$ It sounds like you have a keying set active. What happens if you delete it or disable it in the header of the timeline? $\endgroup$
    – gandalf3
    Oct 7 '14 at 19:56
  • $\begingroup$ still the same. I've seen that the Scene property has a Keying Sets active when I select my camera. As a beginner I have actually no clue how this is enabled after upgrading to 2.72 and what it actually does. héh. $\endgroup$
    – juFo
    Oct 7 '14 at 20:00
  • 3
    $\begingroup$ You may consider to upload a simple problematic file somewhere like pasteall.org then paste the link here. $\endgroup$ Oct 8 '14 at 3:20
  • $\begingroup$ I received instructions to not share the work. Can't reproduce it in a simple file. $\endgroup$
    – juFo
    Oct 8 '14 at 7:10

See screenshot: The solution was to remove the keying set at the bottom and when selecting the camera, to remove the 2 keying sets that were there.

I however have no idea how this was enabled, and at this point of time I also don't know the goal of this keying.

After removal, the I key worked again. enter image description here


You may have locked the editablity of the keyframes for the channel. This means that the little lock icon next to LocRot in the graph editor was pressed. Atleast this is how I've resolved the issue on my laptop :)

  • 1
    $\begingroup$ could you please post a screenshot, indicating the area where to look for the properties mentioned? It will be hard for new or transition users to find it, as not all terms like 'LocRot' or 'graph editor' are known to everybody $\endgroup$
    – aliasguru
    Aug 18 '17 at 12:26
  • $\begingroup$ I found myself in this thread in 2018 so I felt it was worth mentioning. Above, User44922 describes the solution being in the, "graph editor". When I think he meant the Dope Sheet. $\endgroup$ May 30 '18 at 17:08
  • $\begingroup$ In Blender 2.7.9, I selected (in Pose Mode) Pose -> Animation -> Change Keying Set [Shift+Ctrl+Alt+I] - setting this to loc-rot-scale (which is what I needed). You should set the keying set to whatever your require (there are multiple choices). $\endgroup$
    – Epsilon3
    Jun 29 '20 at 23:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.