0
$\begingroup$

Having just ventured into the physics of Blender, I tried to set fire to a cylinder in a previous animation. The results looked nice especially using Cycles. In the 3D viewer with Viewport Shading: rendered turned on.

However, the output does not reach the renderer when trying to output an animation. I tried the same using the default startup scene, setting fire to the default cube. Neither Eevee or Cycles will render anything: Eevee shows a blurry domain box, cycles just shows the cube.

Any suggestions? I use PC (Win 10) with 2x EVGA 1070GTX in SLI. Everything else seems to render fine, just not physics (or at least not fire + smoke for now).

Thanks for your help, S

$\endgroup$
1
  • $\begingroup$ Alright, found a worked-only-once partial solution: I deleted the basic output shader for the material on the Domain cube and added a new basic output back in. The fire effect disappeared, but now the smoke rendered in Cycles. It worked only once though. The issue does seem to be with how the Domain box is rendered, which for some reason works fine in the Preview window but not in the final F12 render. $\endgroup$
    – Sysmon
    Commented Jan 29, 2020 at 1:59

1 Answer 1

1
$\begingroup$

In the end, it was possible to "jog" Blender into rendering a frame of a burning basic torus using the default settings for Quick Smoke + Fire. I changed CUDA settings to CPU only and replaced the Output shader with a fresh default one. The fire + smoke then F12 rendered, if slowly.

When I then turning GPU Compute back on (and all GPUs + CPU on as well in CUDA settings in Preferences), the fire + smoke still rendered, and a lot faster. Have the Blender devs added GPU support to Cycles with 2.80? If so, thank you! I just find it strange that the Material Output shader needed replacing to get the physics effect to run.

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .