5
$\begingroup$

I am making a harry potter video with friends and I'm adding magic between the 2 wands. I'm using 2 particle systems with gravity off pulled by a force field for the magic and killing them when they hit the center with an invisible circle with collision kill particles. it looks great in the viewport but when I render it doesn't kill the particles. in the beginning, I thought it had to do with the 2 view layers I have so that a stone wall will be clear and the magic will be blurred and will have haze without volumetrics but my moving it around trying to solve the problem didn't seem to help.

viewport - this is what it looks like in the viewport

render-and this is what it looks like in the render

there is a circle with kill particles notice the circle in the center, it has kill particals

these are the collision settings these are the collision settings

view layer 1 outliner (blur + haze) view layer 1 outliner (blur + haze)

view layer 2 outliner (stone wall) view layer 2 outliner (stone wall)

I don't think it has anything to do with it but here is the compositing (maybe has to do with rendering or somthing) - compositing

and lastly here is the bled file - https://drive.google.com/open?id=1P8E1CuaPaVcRmHLIN59RoRzWov3QwpWW

$\endgroup$
  • $\begingroup$ no, I'm trying to make it not look like in the rendered picture in which the particles don't stop and die from the collision object $\endgroup$ – J Block Jan 31 at 13:17
  • $\begingroup$ they just keep on going $\endgroup$ – J Block Jan 31 at 13:17
  • $\begingroup$ Ok. I just notices that. $\endgroup$ – Nate_Sycro27 Jan 31 at 14:20
  • $\begingroup$ do you know how to solve it? $\endgroup$ – J Block Jan 31 at 14:48
  • 1
    $\begingroup$ Do you already tried caching the particles to disk? (Particle Properties > Cache > Disk Cache) @JBlock $\endgroup$ – brockmann Feb 1 at 20:54
4
+50
$\begingroup$

To prevent internal or viewport cache errors, save your particle cache to the disk before rendering. Enable Disk Cache under Particle Properties > Cache and click Bake all Dynamics:

enter image description here
Cache panel

enter image description here
Frame 7200 - 7325 cached to disk and rendered with Eevee

For several reasons but mostly because of the colour range provided by some of the available image formats, I suggest render your animation to an image sequence (preferably .exr) and compile the images into a video container like .mov, .mp4 or whatever afterwards.

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Same Issue came up today again: blender.stackexchange.com/a/165640/31447 $\endgroup$ – brockmann Feb 1 at 22:03
  • $\begingroup$ The answer to this question that you have provided is virtually identical to my answer. $\endgroup$ – Nate_Sycro27 Feb 1 at 23:38
  • $\begingroup$ Any arguments or facts to support your statement? @Nate_Sycro27 $\endgroup$ – brockmann Feb 2 at 13:27
  • $\begingroup$ No. Just that it is not really a good idea to post another answer containing similar material to the former answer previously posted. I.e. .png image sequencing. $\endgroup$ – Nate_Sycro27 Feb 2 at 14:36
  • $\begingroup$ I would never suggest rendering to png (worst file format ever) and havn't done that here (fact) so what's your point? @Nate_Sycro27 $\endgroup$ – brockmann Feb 2 at 14:48
1
$\begingroup$

Note: You are using EEVEE

I tried your settings, and it worked fine for me in Cycles. I noticed that you are using EEVEE for rendering, and if you want to escape volumetrics by using compositioning then you should use cycles.

If you want to continue using EEVEE, then I would recommend using volumetrics, as opposed to compositioning.

However, if you do switch to cycles, then you can use compositioning for achieving a "volume" look.

When I tried your .blend on another PC, the particles did not continue to show bouncing off of the cylinder when using cycles, (which is what I thought you want), so that must be the answer.

If that doesn't fix it, try rendering as a png sequence, and then using the video sequencer.

| improve this answer | |
$\endgroup$
  • 3
    $\begingroup$ that didn't solve it. my problem isn't the volume its that when rendering the animation it ignored the kill particles collision object which it calculated when in the viewport. thanks though. $\endgroup$ – J Block Feb 1 at 16:16
  • $\begingroup$ Have you tried png image sequencing? There have been many problems with people that straight up render animation video output. $\endgroup$ – Nate_Sycro27 Feb 1 at 16:26
  • $\begingroup$ cool that also worked thank you $\endgroup$ – J Block Apr 21 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.