1
$\begingroup$

I recently downloaded one of Kitbash 3D's scene kits, for use in Blender. The download comprises two parts: a Blender-specific file containing the buildings, and a folder containing all required texture files.

The building file loads successfully in Blender, but buildings are displayed in a default colour (bright purple!). Blender users will know that in the program's Shading set up, texture files are attached to a system of nodes. Now, when I looked at my Blender, it looked like the texture files were in place, but somehow weren't being 'read'. As an experiment, I tried replacing one of the dummy textures with a copy from the folder - and it worked!

I'm sorry if I haven't explained this very clearly. However, I hope someone might be able to give me a nudge in the right direction.

$\endgroup$
1
$\begingroup$

The bright purple colour indicates an image can't be found.

Use File->External Data->Find Missing Files to choose a folder containing the textures it is looking for, which may be the folder above the one with images in it. It may be that the texture folder is meant to be moved inside the object folder not next to it.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.